Alien Storm Repair Logs

From Arcade Otaku Wiki
Jump to: navigation, search

Repairer: Womble
Forum Thread: Alien Storm PCB Repair

Got a parcel from Prktkljokr today with a couple of untested Sega System 18 boards inside, one was a Shadow Dancer which turned out to be working 100% and the other was Alien Storm.

Pcb repair alien storm 1.jpg

This board was not in good health, when powered up I got a black screen, a blast of random sound effects from the game out the speaker and then silence. The board itself was in pristine condition, not a scratch or a dent on it, apart from a single cap that had been wrenched clear from its mountings...

Pcb repair alien storm 2.jpg

...for it to give way so cleanly...

Pcb repair alien storm 3.jpg

...the joint had to be pretty crappy to begin with. It was not likely to be causing my issue as its is a smoothing capacitor and the board has others, but I fitted a 470uF 16V cap and tidied up the dry joints on a few other caps. Generally it is a bad idea to go around reflowing solder joints but on a couple of the smoothing caps they were really obviously bad.

Pcb repair alien storm 4.jpg

As it still had its encrypted battery backed FD1094 CPU block on the board the most likely cause for its odd behaviour was that the battery had finally given up after 22 years and the data in the decryption RAM contents were now lost. Fixing this is pretty easy these days, you just burn 2 new replacement EPROMs that contain the unencrypted CPU code and drop in a bog standard 10Mhz 68000 CPU to de-suicide it.

Pcb repair alien storm 5.jpg

On power up I got this...

Pcb repair alien storm 6.jpg



Pcb repair alien storm 7.jpg

... the board was now alive but the graphics were pretty messed up.


So I grabbed some wire and shorted the relevant pins on the JAMMA connector to get into the diagnostics menu, somewhat painful on this board as every test is a separate menu you have to hop through, not easy with a bit of wire, I really should wire up Service and Test buttons on this harness - one day perhaps.

All tests passed OK except this one...

Pcb repair alien storm 8.jpg

... but the tests on this board are too quick to be overly in-depth, but I do have a Moonwalker ROM board that has a diagnostics mode that has a far longer set of tests. So I swapped the boards over, and the support MCU that Moonwalker needs and fired up the diagnostics...

Pcb repair alien storm 9.jpg

... this ended up going nowhere as the results was such a garbled mess and the board had locked up. I also tried the VDC chip (IC64) tests which failed horribly which was rather worrying as that is a fat custom chip that I know absolutely nothing about.

IC35 is a Hitachi HM65256 SRAM chip and it is well hidden under the ROM board, so poking a scope at it when the board is running involved having the board upside down and working on the pins from underneath, this didn't really show anything as all the signals looked perfectly healthy.

With not much else to go on the simplest thing to do was to rule out that chip, desoldering on Sega boards of this vintage is an absolute breeze...

Pcb repair alien storm 10.jpg

...the thru holes are fairly large and the chips can be made to just drop off the board. With it off the board I slapped it into my VP-280 EPROM reader, selected the correct SRAM chip from the list and tried to program it...

Pcb repair alien storm 11.png

...FAIL! This is what I was hoping for, the PCB diagnostics actually had no idea that this chip was bad, all it knew was that it tried to send it some data, then tried to read it back, it compared what it sent with what it got and gave the "BAD" message as they were not the same. It could be all manner of faults, track damage, bad control logic or an actual bad chip. Anyway in this case the chip was bad, with an "out of spec" power pin, looks like it got zapped. As the board has no feet it is possible it touched something conductive while it was running and the chip got fried, no way to know for sure.

So I pulled another HM65256 off a scrap CPS1 motherboard and tested that, it passed the tests so it was soldered into the board.

With the board complete I powered it back up...

Pcb repair alien storm 12.jpg



Pcb repair alien storm 13.jpg

... all working. By the way, the crazy pink hue is my camera having a bad day, any screen photos without flash just come out pink for some reason, hopefully it is not on its way out.

To double check the board was now A-OK I ran the diagnostics again...

Pcb repair alien storm 14.jpg

... and again with the Moonwalker ROM board installed for the more indepth tests...

Pcb repair alien storm 15.jpg

... even the VDC tests now pass, so clearly that has a dependency on this RAM and probably its neighbour.

Job done, and a nice easy fix for a Monday night


Repair Logs converted to wiki format by Brad from Aussie Arcade.